用户名:  密码:  验证码: 验证码  注册  找回
RSS
无双网
 2019年09月23日 星期一  您现在位于: 首页 → 技术文栏 → ESX 补丁不按顺序安装造成的downgraded...

ESX 补丁不按顺序安装造成的downgraded错误的解决方法

2011年06月13日  无双网  出处:
关于ESXpatch的新进展
对于ESX的patch,一直是要求按照日期的排列顺序来进行补丁的安装,
否则就会出现一些补丁打不上,出现“1 packages need to be downgraded.”的错误。
虽然是很注意了,但我打补丁的时候还是出现这样的问题,
不过事情有了进展,vmware的patch主页上出现了个新的链接/20101129233143132
用—force参数就可以强行安装不能打上的补丁了。(不过用这个参数前要进行以下步骤)
1. 登陆console里,使用root权限,
运行了补丁(esxupdate update)后,
再运行grep -i downgrade /var/log/vmware/esxupdate.log
会显示类似下面的信息:
[07Apr19-0832] DEBUG: session: downgrade pend : VMware-esx-vmkernel.i386
[07Apr19-0832] INFO: root: 1 packages need to be downgraded.
2. 然后运行esxupdate –x VMware-esx-vmkernel.i386 update
(加粗的为之前显示的包,如果显示有多个“packages need to be downgraded.”
可以运行 esxupdate –x VMware-esx-vmkernel.i386 –x VMware-esx-scripts.i386 update
将VMware-esx-vmkernel.i386 和VMware-esx-scripts.i386两个包 一起运行)
3. 比如我这里有个补丁包(ESX-2092658)没打,将该补丁包解压到ESX某文件夹中,进入该路径
运行[color=Red]esxupdate - -force update[/color]即可。
另外,打补丁有个工具(VMTSPatchManager)真的很好,方便好用:/20101129233144133.htm

原文地址:/20101129233144134
 (本文已被浏览 445 次)
 发布人:[标签:发布人]
 → 推荐给我的好友
上篇文章:VMware VM迁移与备份方法
下篇文章:ESX Server 3i&nb...
发表评论
  → 评论内容 (点击查看)   共0条评论,每页显示5条评论   浏览所有评论
(没有相关评论)
  → 发表我的评论 (点击发表)
热门文章
 保存webbrowser中的HTML内...
 用VB6.0设计简易赛车游戏
 MSFlexGrid使用技巧一例
 游戏对照表
 Win2003+Discuz!5.5+II...
 全部DLL下载
 添加红月装备的详细教程 (包括装备 武...
 在Delphi里播放Flash
 用vb6的ActiveX控件实现异步下...
 能否判断动态数组有没有被分配过
最新文章
 [ODBC SQL Server Driv...
 评论:115网盘的何去何从
 我科学家实现百公里量级自由空间量子隐形...
 中国智能手机出货量占全球27%居世界之...
 Gartner:2012 第二季度西欧 P...
 [多图]华山论剑:当今在世的智商最高的...
 三星获出租车服务系统专利 可快速查看驾...
 [多图]15项可能延续到2030年的科...
 分析称苹果三星专利大战输赢已成定论
 Google终获云操作系统专利
 网站留言· 友情链接·与我在线·网站地图联系我们·管理·TOP 
 陕ICP备14011112号  
 Copyright © 2012 Asp126.com Inc. All Rights Reserved.Processed in 0.016s, 8 queries, 35 Cache,0 Online